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Advanced Remedy Topics 
Training Notes 

This document is maintained on the Web at: 
http://remedy.ncsu.edu/training/ 

 
1.0 Introduction 
 
The Remedy AR System has been in place at NC State since early 1999, and has met 
with great success. As of this writing, over a dozen support organizations on campus use 
Remedy to log, track, and resolve issues involving campus issues, both computing-related 
and others. As the use of Remedy spreads, so does the need for some of the more 
advanced features of Remedy. For this reason, the Advanced Remedy Topics course was 
written. This course is designed to pick up where Using the Remedy AR System 4.5 at NC 
State left off, going into greater detail about searching, macros, and reporting. A basic 
knowledge of Remedy and its implementation is required before participating in this 
training. 
 
2.0 Searching for Calls 
 
The Remedy Implementation team has done a fine job of setting up the Calls form so that 
several of the more common search methods are available at the click of a button, 
including searching your default workgroup, your owned calls, etc. But, try as they 
might, the team can only devise so many generic searches, and there is only so much 
room on the form for buttons. You will eventually need to search Remedy for something 
unique, whether it is calls you logged over the past week, or all calls logged into your 
workgroup that were resolved in less than an hour, etc. Remedy AR User is equipped to 
allow you to make these sorts of highly flexible searches. 
You can search the database behind the Calls form (or any form, for that matter, but for 
sake of brevity, we’ll concentrate on the Calls form) by using the Search window of 
Remedy AR User. You do this by bringing up the Calls…Find view, similar to how you 
probably check Remedy on a regular basis: 
 

 
 
Once the view appears, do not click on any of your usual buttons. This is the Search 
window, and you want it as empty as possible. To locate specific calls, you must specify 
certain search criteria. You can specify search criteria in one of three ways – query-by-
example (or QBE), by using the Advanced Search Bar, or by using a combination of 
both of these methods. 
 
2.1 Query-by-example (QBE) 
 
The quickest and easiest way to search for calls is to fill in fields in the form that match 
the calls you want to find, and click Search. This is query-by-example. 
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In the above example, the search would find all calls with Priority “High” that the 
Remedy user “chking” had been the last user to modify. Workgroup, Owner, and Status 
would not matter, since those were not listed as criteria for the search. Keep in mind that 
since Remedy searches for calls that match all of the fields you gave values for (this is a 
logical AND operation), the more criteria you fill in, the more specific your search 
becomes. 
One thing to note – the Search Calls form must be completely empty before a QBE 
search is performed, to avoid searching for criteria you did not intending on searching 
for. Even though you can’t see a space in a field, for example, doesn’t mean Remedy 
won’t search on it. To make absolutely sure, click on the Clear All button (or use the 
shortcut Ctrl-E) to clear all fields before beginning your search. 
Also, the standard Calls form cannot be used to search using customer data as search 
criteria. For this, you will need to use a special form, the “Calls_Cust” form, which is 
detailed below. 
 
2.2 Advanced Search Bar 
 
Another method for specifying search criteria is to use the advanced search bar. The 
advanced search bar is used when you want to define a search that is more complex than 
simple query-by-example, such as searching on a range of criteria. To display the 
advanced search bar, click on the Advanced button, or select Advanced Search Bar from 
the View menu. 
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There are three parts to search criteria within the advanced search bar: the field name, the 
operator, and the field value. 
Field names are the names of the fields in the Calls form that you are searching on, such 
as ‘Workgroup’, ‘Status’, etc. Field names are always put into the advanced search bar in 
single quotes. You can enter a field name into the advanced search bar either by typing its 
name, selecting it from the Fields menu on the right-hand side of the advanced search 
bar, or by clicking on the field label in the Calls form. 
An operator is the comparative symbol you will use with your search criteria. The third 
palette at the top of the advanced search bar has the operators more commonly used with 
searches. 
 
= (is equal to) <= (is less than or equal to) 
!= (is not equal to) >= (is greater than or equal to) 
< (is less than) 
> (is greater than) 

LIKE (this is used for a pattern search, 
and is often used with the % character) 

 
These operators are great for doing comparative searches, such as finding calls logged on 
or after a certain date, calls logged by everyone in a workgroup but a specific person, and 
so on. The LIKE operator seems the odd man out in this list, and it is a bit more 
complicated. The LIKE operator is used to perform a pattern search with a wildcard 
character (for AR User, the wildcard character is %). For example, ‘Problem Description’ 
LIKE “Alb%oss” would find all calls with a Problem Description that began with the 
letters “Alb” and ended with the letters “oss”, such as Albatross or Alby gave his 
computer a toss. Now, since this is a comparative text operator, it is only good in text 
fields within the Calls form (and would not work on ‘Create-date’, for example).  
Field values are the meat of your search – they are the values you are comparing against 
the larger list of calls in the database. Some field values are listed in the Fields menu on 
the right-hand side of the advanced search bar, but you will probably want to enter your 
own field values into the advanced search bar. All non-numeric field values are put into 
the advanced search bar in double quotes. Some fields in the Calls form, although they 
look like text fields, are actually numeric behind the scenes, and you can use this to your 
advantage. ‘Status’ ‘Priority’, ‘Origin’, and ‘Impact’ are four such fields, and their listing 
in the drop down menu is in descending numerical order. For example, the ‘Priority’ 
menu items have the following values: Low = 0, Medium = 1, High = 2, and Critical = 3. 
So, if you wanted to search on which calls had a Medium, High, or Critical priority, you 
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could search for ‘Priority’ > “Low” or ‘Priority’ >= “Medium”. Also, there are several 
keywords that you can use for variable searches – use the keyword, and Remedy fills in 
the appropriate corresponding value. 
 
Keyword Substituted Value  
$DATE$ Current date. In a date/time field, the time defaults to midnight 

(00:00:00) 
$NULL$ A null value, basically a place where no value was given 
$TIME$ Current time. In a date/time field, the day defaults to the current date. 
$TIMESTAMP$ Current date/time stamp. 
$USER$ Name of the currently logged in user. 
 
The other operators listed on the top of the advanced search bar are for expanded 
searches, where more than one comparison is needed. 
 
Operator Action 
( ) Parentheses are used to separate individual comparisons used in a 

search. 
AND 
 
&& 

The search will only find calls where both conditions joined by 
AND are met. For example, ‘Status’ = “Assigned” AND ‘Agent’ = 
“nlil” finds all Assigned calls logged by user nlil. You can also use 
the symbol && instead of the word AND. 

OR 
 
|| 

The search will find calls matching either condition joined by OR. 
For example, ‘Status’ = “New” OR ‘Status = “Waiting” will find 
all calls that are either New or Waiting. You can use the symbol || 
(two pipes, usually above \ on a keyboard) instead of the word OR. 

NOT 
 
! 

The search will find all calls where the condition is not met. For 
example, NOT ‘Origin’ = “WWW” will find all calls not 
originating off the Web. You can use the symbol ! (sometimes 
called bang) instead of the word NOT. 

+ • Adds two integer or real values 
• Adds an integer interval to a time value 
• Concatenates two character strings 

- • Subtracts two integer or real values 
• Subtracts two time values 
• Subtracts an integer value from a time value 

* Multiplies two integer or real values 
/ Divides two integer or real values 

 
Operators have precedence over one another (anyone remember PEMDAS from 
Algebra?), and the following list shows operator precedence in order. 
 

1. ( ) 
2. !, NOT, - (negative numbers) 
3. *, /, % 
4. +, - 
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5. <, <=, >, >=, =, != 
6. && (AND) 
7. || (OR) 

 
Here are some examples of searches in the advanced search bar. Can you tell what calls 
they will find? 
 
‘Status’ = “New” OR ‘Status’ = “Assigned” 
 
‘Agent’ != “mapittm2” 
 
( ‘Problem Description’ LIKE “%policy%” OR ‘Workgroup’ = “POLICY” ) AND ‘Priority’ = “High” 
 
2.3 Time and the Advanced Search Bar 
 
You can also use the advanced search bar to search for ranges or comparisons in date and 
time. There are two ways to specify time in a search: absolute time and relative time. 
Absolute time is the simple way to search using a time or date, since you are comparing 
to a specific time or date. For example, 
‘Modified Date’ > “10/27/00” 
 
would find all calls modified since October 27, 2000. Keep in mind that Remedy assumes 
you mean midnight (00:00:00) of the absolute date you give. 
Relative time  is used when you do not want to give a specific time or date in a search. 
Most often, this is used in macros (explained later), where a search is saved for later use. 
In these cases, you would give Remedy a time/date keyword and a range of seconds that 
you want to search on. Yes, that’s right – seconds. Remedy keeps time and dates stored in 
epoch time , which is defined as the number of seconds since January 1, 1970 at 12:00 
am. So, when you want to search for all calls logged in the past 24 hours, you would use: 
 
‘Create Date’ >= $TIMESTAMP$ - (60*60*24) 
 
This finds the calls logged in the last 86,400 seconds (86,400 seconds = 60 seconds in a 
minute * 60 minutes in an hour * 24 hours). And, since no specific date is given, this 
search pattern can be used in a macro later without having to change the text of the 
search. 
Here are examples of commonly used time/date searches: 
 
'Agent' = "tmfarwig" AND ('Resolved Date' - 'Create-date') <= (60*60) 
 
This finds all calls logged by “tmfarwig” that were closed/solved in less than one hour. 
 
'Workgroup' = "CONSULT" AND 'Create-date' >= $TIMESTAMP$ - (60*60*24*7) 
 
This would find all calls in CONSULT logged in the past week. 
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2.4 Status History 
 
Sometimes, it is nice to know more specific details about a call’s Status. For example, 
when a call was set to Owned status, and even who set that status. Remedy has a core 
field (a field that is in every Remedy AR User form, no matter what the administrator 
changes) called Status History  that keeps track of these things – specifically, the times 
and agents involved whenever the status of a call changes. To view the complete Status 
History, select Status History from the View menu in Remedy. 
 

 
 
Unfortunately, our workflow allows us to revisit a status – a call that was Closed can be 
made Active again, for example. Status History overwrites itself, and only keeps track of 
the most recent status change for a particular status. 
To use Status History in a search, you must enter it in a specific format. For example, to 
find the last User to change the status of a call to Owned, you would use the field name: 
 
‘Status-History.Owned.USER’ 
 
You can replace Owned with any of the options in the Status drop-down menu, and you 
can search for USER or TIME. 
 
2.5 My Searches and Recent Searches 
 
As you get more and more familiar with the advanced search bar, you will see that your 
searches are long and convoluted, and a pain to retype. Remedy thought ahead of you on 
this one – Remedy keeps track of your recent searches, and it is possible to save common 
searches in Remedy for later use. In the Search Calls view, notice the arrow next to the 
Search button. This is a drop-down menu with a list of your recent and saved searches. 
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There is also a place here for searches defined by the Remedy administrator (Defined 
Searches), but at this time, there are no administrator-defined searches. 
Recent Searches will show you the last few searches that you’ve performed in the Calls 
form (or whatever form you are currently working on), which is convenient for repeating 
a search you’ve just done. However, the menu can only hold a few searches, and 
eventually you will end up overwriting your searches. For the important ones, you’d be 
better off saving them. 
My Searches shows a list of the searches that you’ve saved. To save a search, first define 
your search by filling in your QBE fields and/or any searches in the advanced search bar. 
Then, choose Save Search from the Actions menu, and give your search a name. 
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The search will be saved into your AR Home folder (defined by going to the Accounts 
option in the Tools  menu), and can be used from any Remedy client that uses that same 
AR Home folder by choosing the search from the My Searches option.  
 
 
 
2.6 Using customer data as search criteria 
 
The Calls form is a join form, which means that it extracts data from two sources, in this 
case data from the Calls database and data from the Customer database. The Customer 
data is in a read-only format, and is only linked to the Calls themselves – the customer 
data is not part of the Calls database itself. For this reason, the Calls form cannot be used 
to search based on customer data. If you would like to run a search based on customer 
data (such as how many calls did a certain person report, or how many calls originated 
from the same department [and OUC]), you will have to use another form. The 
“Calls_Cust” form is used for this purpose. Except for the layout of the form itself, it can 
be searched the same as the Calls form, and will get you the data you need for your 
subsequent reporting. 
 
3.0 Reporting 
 
While a search can generate a window full of calls, most of the time a user will only want 
a summary of those calls. That is where reports come into play. Remedy’s report 
generation allows you to export a file containing only certain fields in those calls, 
allowing for easy summariza tion of the activity in a given group of calls. The reporting 
feature also allows for sorting and grouping, but for reasons we’ll discuss later, this is not 
suggested. 
 
3.1 Creating a new report 
 
Your first step is to create a new report. To do this, choose Reporting… from the Tools 
menu. Then, double-click on the <<New Style>> heading to bring up the default report 
properties. 
 

  
  
First, click on the General tab, and give your report a name. Reports are saved, and can 
be used repeatedly. Next, click on the Fields tab, and begin selecting the fields you want 
to appear in your report. As you select fields to enter into your report, notice that you can 
put fields before or after others, and that you can also modify the Report Label (the 
heading for that field in your report) and Width (the number of characters displayed for 
that field). Keep in mind that some fields take more or less characters than the default 20 
– the Agent and Owner fields in Remedy, for example, will never be over 8 characters in 
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length, while Problem Description can be over 30 (and don’t even bother with Text 
unless you deem it necessary). 
 

 
 
If you add a field and later want to change its place in the order of the fields, you will 
have to remove it and place it again later. Once you have your fields as you like them, 
click Apply to get a preview of how the report will generate – the Style Preview will 
appear in the bottom half of the main Remedy report window. 
 

 
 
The next two tabs are Sort and Statistics. Remedy has the option of letting Remedy itself 
sort and analyze the data. However, Remedy does not behave as it should with our 
Sybase database, and the SQL statements that Remedy uses to perform sorting and 
collating are problematic. It is better to export your data as a raw file, and use another 
program (such as Microsoft Excel) to sort and summarize your data. 
For now, go to the Page Setup tab to define the format of your report.  
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How you make these settings is entirely up to what you want to do with the report. The 
above report has been made for ease of reading (columned format, relative header and 
footer, titles every page, etc.), but not necessarily for exporting into Excel (titles every 
page would skew your data). The Style Preview window will show you the basics of what 
you are doing, so take time to get your report exactly how you (or your target audience) 
would like it to format, clicking Apply to see your most recent changes. Also keep in 
mind how these settings affect others in your report. For example, the Chars per line 
setting (in the above example set to 92) should at last be as long as the sum of the Widths 
for your fields in the Fields tab, so that they display properly. Otherwise, you should go 
back to the Fields tab and shorten some Field Widths to match. 
One important setting in Page Setup is the Report Format. How your report is formatted 
is determined by what you intend to do with the report after it is generated. Formatting by 
record lists the calls in order, with field labels for every listing. 
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This style of formatting is good when you want a summary of the calls for review and 
analysis, since multiple pages are easier to read when divided. Formatting by columns 
lists the calls in order, and has field labels every page. 
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When formatting by column, you should  pay attention to the Long Field Format from the 
Page Setup tab in the Report Properties. If you select Wrap, a field longer than the Field 
Width you set under the Fields tab will wrap to conform to the column width. 
 

 
 
If you would rather the column cut off the extraneous text, select the Truncate option, and 
the text will stop once the column Width has been reached. 
 

 
 
Formatting by column is useful when you want a quick list of calls for viewing, or when 
you want to export the file into another application. 
Formatting by Compressed Text is most useful when exporting data into another 
application. It is not very friendly to the eye, but can easily be read by another program. 
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Now that your report is like you want it, it is time to save it. You can save your report by 
selecting Save from the Report menu in the Report Styles window, or by clicking on the 
diskette icon. 
 

 
 
3.2 Generating a Report 
 
Once you have your report formatted, you should generate a real report. First, you must 
have data to report on, either by defining search criteria in the Calls window or by 
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selecting calls from the results of a search. The first is the most expedient – just enter 
your search criteria into a blank Search Calls window (either QBE or in the advanced 
search bar), then go to the Reporting window (Tools… Reporting). In this case, 
especially when using the advanced search bar, make sure that your search will run 
without errors, or else this quick method will take longer than you might like. A safer but 
slower way is to run a search, and highlight the calls you want to report on (or leave them 
all unselected, and it will still search on all records), and then go to the Reporting window 
(Tools… Reporting). If you want all the calls in your report, the easiest thing to do is to 
highlight the first call in the search, then Shift-click the last call in the search, which will 
highlight all the calls. Once in the Reporting window, right-click on your report, and you 
will be given a set of options. You can Preview the output or send the report straight to 
the printer using the Print command, but most likely, you will want to save a copy. For 
that, you would Export the file. 
 

 
 
When saving reports, as with selecting formatting options, what you select depends on 
what you intend to do with the results. Saving as Report Files will save the output to a 
text file in the format you saw in the Style Preview window. Comma Separated Values is 
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a good format if you are going to use another application to manipulate your data. AR 
Export files are for when you want to import report data back into another form within 
Remedy, so you likely will have no real need for that option. 
 
3.3 Manipulating report data 
 
As was mentioned before, the built- in sorting and manipulating features of Remedy are 
somewhat lacking in our implementation here at NC State, due to the programming used 
by Remedy to interface with the Sybase database we use. For this reason, another 
program is needed to get any real quantitative data out of Remedy reports. Although you 
can use whatever program you work best with, we will demonstrate some common 
methods of data manipulation within Microsoft Excel. (For the examples below, Excel 
2000 is used.) 
When using Excel, it is better to have your report as Comma Separated Values, since that 
is one of the more common file formats for Excel. Open the file with Excel, and Excel 
should (depending on which version of Excel you have, among other factors) open the 
file in a spreadsheet: 
 

 
 
From here, what you do with Excel to manipulate your data is limited only by what you 
can squeeze out of Excel. In the example below, we will use the Sort and Subtotals 
features (from the Data menu) and the Chart Wizard to get a graph of the number of 
calls in this report for each Agent. 
First, with the report open in Excel, we need to sort the data by Agent. So, select all the 
calls in Excel by click-and-dragging the column headers for all the columns your data 
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uses. (Or, you can cheat and use Ctrl-A to Select All.) Now, go to the Data menu and 
select Sort, and a dialogue box will come up: 

 
 
Select Agent for “Sort by”, and click OK. 
Now we need to get a count. Excel is a number cruncher, so we need to get a count of the 
calls logged by each Agent. To do this, select the column you want to count (in this case 
column B). Then, go to the Data menu and select Subtotals. (Excel may give you an error 
about not knowing what the header of the column is. The Remedy report should have 
given you a header in row A, so just click OK to the error message.) 
 

 
 
Make sure that you’re counting changes in the right column (in this case Agent), and 
click OK. Excel will count the number of rows, and provide subtotals at the end of each 
Agent’s calls. 
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With the subtotals now available, we can use the Chart Wizard to get the numbers into a 
nicer format. First, we need to get the numbers out of this spreadsheet and into another 
one. Scroll down in your spreadsheet, and look for the subtotal lines. They will be in 
bold, and will have the word Count in the field. In addition, there will be a small – (minus 
sign) icon beside each subtotal. 
 

 
 
Click on each minus sign, (or the number 2 at the top above the minus signs) and that will 
group all of the subtotals together at the top of the spreadsheet. Once you have them all, 
select all of the subtotals (and the subtotal names). Since there are hidden rows here, you 
will then have to go to the Edit menu and select Go To… On the next popup box, click on 
Special, and check Visible Cells Only. That will ignore the rows that aren’t shown, and 
select just the summary fields that we want to chart. Now, copy them, either by using 
Ctrl-C or by selecting Copy from the Edit menu. Next, insert a new worksheet into the 
spreadsheet by choosing Worksheet from the Insert menu. Paste the values of your copies 
subtotals into this new worksheet. Be sure to use the Paste Special option from the Edit 
menu for this, and choose the Values option: 
 

 
 
This will make sure that the numbers in the fields, and not the subtotal Excel formula, get 
pasted. (Depending on your version of Excel, you may need to sort this second page, as it 
may paste too many rows, forcing you to sort for the Count fields). Select these fields, 
and click on the Chart Wizard button: 
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Select the chart you would like, and any extras you want to add to the chart, and Excel 
will do the rest. In this example, the Pie chart was selected, with values shown, and the 
result is this: 
 

 
 
Depending on your needs, experiment with Excel, and you can easily get the charts you 
need. For more information on Excel, you should check out: 
 
http://www.microsoft.com/office/support.htm 
 
4.0 Macros 
 
As you use Remedy more and more, you will likely find that there are a few series of 
tasks that you do over and over aga in. For example, you might come in on Monday 
morning and search for all calls in your workgroup. Then, you make a report out of that 
search, and export it to a file. With Remedy, it is possible to automate this process using a 
macro. A macro is a preset list of operations that Remedy will perform whenever you 
ask. Remedy makes this even easier by having the option to record the macro – that is, 
Remedy will watch you do something, and keep track of everything you did. Then, it will 
do things exactly like that whenever you ask. 
Before you create a macro, it is a good idea to close all windows within Remedy. That 
way, you will open all necessary Remedy forms while recording the macro, and you 
won’t have to rely on forms being open when the macro is run. Once Remedy is clear, 
you can start recording the macro by selecting Record Macro from the Tools menu: 
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Then, immediately begin performing your normal actions. If you make a mistake, you 
can select Cancel Recording from the Tools menu and start over. Once you’ve done 
everything you need to do, select Save Macro from the Tools menu, and give your macro 
a name. That’s it! Whenever you want to run your macro, select Run Macro from the 
Tools menu, select the macro you want (you can have multiple macros), and click OK. 
Remedy also makes it possible to add variables to your macro, so that the macro prompts 
you for field values every time you ran the macro. From the Help index of AR User: 

 
You can record a macro that enables you to change certain values when you run the 
macro. That is, when the macro is running, you can enter variable values in the 
appropriate fields. For example, you could create a macro that finds and displays 
assigned requests that have a critical priority, but you would also specify a different 
submitter each time you run the macro. 
To create this macro with variables, you record the search operations as usual; but for the 
information that varies, you enter prompt text enclosed by dollar signs ($). In this 
example, to be able to specify the submitter each time you run the macro, enter the 
prompt text $User Name$ instead of a specific name in the Submitter field. 
As you continue recording the search, you are prompted to enter a sample value for this 
variable. The values you enter are used in the recording session but are not retained as 
part of the macro. 
Note: 
You cannot include dollar signs ($) as part of the variable. 
For selection fields (radio button and drop-down lists), you must use the advanced search 
bar to specify variable values.  

 
 

5.0 Conclusion 
 
This should hopefully give you the additional knowledge you need to make full use of the 
potential and capabilities of Remedy. As you use Remedy more and more, you will get 
used to its basic features as well as get introduced to its more advanced capabilities. For 
more information on the Remedy implementation at NC State, please send email to: 
 
remedy@ncsu.edu 
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